Connection issues for generation 1 watches (Android Wear 1.5)

Please share:
I still have a Generation 1 watch (a Moto 360), which I regularly test my app with.

Troubleshooting connectivity

Please see my post “Fixing Connection Problems” for general troubleshooting for connectivity issues.

The newest version Wear OS has trouble transferring the Android Wear component to the watch. Because of a November policy change, Google no longer allows me to publish the updates of Bubble Cloud which is targeted at older watches. Starting November 1 only the encapsulated version could be “smuggled” in, but it seems the newest version of Google’s Wear OS app doesn’t transfer it any more. The phone and watch components of Bubble Cloud have trouble communicating because your watch has a much older version (9.42) than your phone (9.50).  Version 9.50 for your watch is encapsulated inside the phone APK, but it is no longer seems to be transferred to the watch by the new version of Google’s Wear OS app.
You can read more about the  background of this whole situation on my website: https://bubble.dataglobe.eu/2018/11/02/minor-update-v9427-ironing-out-the-kinks/
Unfortunately Google seems to play a heavy hand to force us to abandon support of gen 1 watches :(((
Better news

For the time being, we still might have one last workaround: on my test device (Moto 360 gen 1) I was still able to install the newest version by downgrading the Wear OS app on my phone to an older version, which still supports encapsulated Android Wear components. You will need to uninstall the current version and get the oldest version which can still be installed from APK Mirror (2.10 or 2.14?):

After downgrading WearOS you might need to install my app again. Sometimes a new update to my app can also trigger WearOS to transfer the encapsulated component. I am planning to publish a new Beta version later today, if you don’t succeed with version 9.50, please join the beta test community and soon I will post a newer subversion of v9.51, which will hopefully install on your watch. Please join the beta test to receive 9.51 right away.

Just wait: it will eventually fix itself

You might not need to do anything special, others with older watches have recently reported success just by waiting half a day… I am extremely sorry and ashamed of the mess Google is making of the Android Wear / Wear OS scene 🙁

Please understand  I am doing what I can, but this is mostly out of my control at this point.

Thank you for your patience!

Keywords: Sony SW3, Smartwatch 3, Moto 360, ZenWatch, LG G Watch, G Watch R, Watch Urbane, Android Wear 1.5

Author: greg

the dev